Fryboyter

Wie Probleme zwischen sddm und den Nvidia-Treibern mein Problem mit Steam gelöst haben

Vor ein paar Wochen wurden die Nvidia-Treiber unter Arch auf Version 378.13 aktualisiert. Eine Installation und ein Neustart hatten immer einen black Screen auf beiden Monitoren zur Folge. Journalctl war der Meinung dass sddm nichts mit der OpenGL-Version anfangen kann (Unrecognized OpenGL Version).

Da alle Suchergebnisse, die sich auf “Unrecognized OpenGL Version” beziehen, absolut nichts gebracht haben, habe ich ein Downgrade der Pakete nvidia-dkms sowie nvidia-utils gewagt. Hierzu habe ich das Tool downgrade aus dem AUR verwendet und beide Pakete in Version 375.26-2 installiert. Und siehe da, sddm hat wieder funktioniert und ich konnte mich normal an KDE Plasma anmelden.

Am Wochenende hatte ich jetzt mal etwas Zeit und ich habe mich auf das Problem gestürzt, da man Downgrades unter Arch eigentlich vermeiden sollte. Da Version 375.26-2 ja funktioniert ging ich davon aus, dass Version 378.13 das Problem ist. Und ich sollte mich irren. Nach x Fehlversuchen habe ich wieder die alte, funktionierende Version der Nvidia-Treiber installiert und wollte fürs erste erst einmal aufgeben. Irgendwie bin ich dann noch auf die Idee gekommen mir glxinfo aus dem AUR zu installieren. Nachdem ich dann glxinfo | grep OpenGL ausgeführt habe, ist mir mein Gesicht mal so richtig eingeschlafen. Eigentlich hatte ich erwartet, dass die Ausgabe etwas mit Nvidia ausspuckt. Statt dessen wurde ich mit Mesa konfrontiert. Um es mal mit dem fränkischen Fragewort auszudrücken… Hä?

Böses ahnend habe ich dann mal nachgeschaut, ob die Pakete nvidia-libgl und lib32-nvidia-libgl installiert sind. Natürlich nicht. Aber warum nicht? Ich bin mir absolut sicher, dass ich diese Pakete installiert hatte. Und ich habe absolut keinen Schimmer warum ich diese deinstalliert haben sollte. Hier wären wir dann wieder beim fränkischen Fragewort mit zwei Buchstaben.

Nachdem ich dann beide Pakete installiert und die Nvidia-Treiber aktualisiert hatte, hatte auch sddm wieder ein Einsehen und der Rechner konnte wie gewohnt gestartet werden.

Einen schönen Nebeneffekt hat das Ganze auch noch. Vor einigen Wochen hatte ich nach einem Update von Steam festgestellt, dass alle Spiele total ruckeln und quasi unspielbar waren. Da ich aktuell fast nur Overwatch bzw. Quake Live unter Windows spiele, habe ich mich damit aber nicht befasst. Aber wenigstens hatte ich am Wochenende mal einen halbwegs vorzeigbaren Geistesblitz und habe 1 und 1 zusammengezählt. Nach mehreren Runden CS:GO war ich mir sicher, dass das Problem mit Steam ebenfalls an den fehlenden libgl-Paketen lag.

Warum aber Version 375.26-2 funktioniert und wieso die libgl-Pakete bei mir nicht (mehr) installiert waren, wird wohl ein Rätsel bleiben. Allerdings haben auch einige andere Arch-Nutzer die sddm einsetzen mit den aktuellen Nvidia-Treibern einen Blackscreen. Vielleicht liegt das Problem dieses eine mal nicht auf meiner Seite…

Linux | OSBN

Keine Maus und Tastatur unter Windows wenn vorher Linux gestartet wurde

Hier mal wieder ein Problem aus dem Bereich “Probleme die der Mensch nicht braucht”.

Auf meinem Hauptrechner ist neben Arch Linux auch Windows 7 installiert das nur für Spiele gedacht ist. Daher wird es auch nicht so oft gestartet. In der Regel boote ich den Rechner erst mit Arch Linux und bei Bedarf mache ich einen Neustart und boote Windows. Hier habe ich nun jedes mal das Problem dass am Anmeldebildschirm weder Maus noch Tastatur funktionieren. Bemühe ich dann die Reset-Taste des Rechners und lasse Windows normal starten funktioniert die Maus als auch die Tastatur. Boote ich Windows gleich als erstes, ist auch alles in Butter. Und genau an dieser Stelle komme ich nicht mehr mit. Ich kann mir beim besten Willen nicht vorstellen, warum Arch Linux hier die Ursache sein soll.

Ein Bekannter, der Computer gerade mal nutzen kann, wollte gestern mal wieder lustig sein und hat mich gefragt, ob ich denn alle Treiber installiert hätte. Gestern hätte ich die Frage noch mit einem Ja beantwortet. Heute eher mit einem Jein. Denn genau mit dieser Frage hat er mich auf die richtige Spur gebracht. Für mein Motherboard gibt es vom Hersteller extra USB-3-Treiber. Da nach der Installation von Windows alles USB-Geräte funktioniert haben, habe ich diese scheinbar nicht extra installiert. Das habe ich gestern mal nachgeholt. Und was soll ich sagen? Jetzt funktioniert auch meine Maus und Tastatur unter Windows wenn ich vorher Arch Linux gestartet hatte.

Was aber schlussendlich das Problem mit den Treibern die Windows mitbringt auslöst, kann ich aber immer noch nicht sagen. Das wird vermutlich auch weiterhin ein Geheimnis bleiben. Ich hake das jetzt mal als “Problem gelöst, Ursache unbekannt” ab.

Allgemein

Was passiert, wenn man mal eben etwas auf die Schnelle macht?

Es geht schief.

So auch das Update auf SMF 2 RC 3. Das wollte ich auch mal so eben machen, weil ich ja eigentlich keine Zeit habe. Fehler. Für so etwas sollte man sich Zeit nehmen. Die Bestrafung habe ich dann sofort erhalten. Fast alle Modifikationen haben den Dienst verweigert. Und das Theme hat auf einmal wie Kraut und Rüben ausgesehen. Die Modifikationen habe ich wieder in den Griff bekommen und das Board ist wieder für Dritte erreichbar. Das Theme verdränge ich jetzt einfach mal bis der Entwickler es an RC 3 angepasst hat oder ich viel Zeit habe. Es zählt ja sowieso der Inhalt…

Allgemein

Der Urlaub ist zu Ende, Der Server ist wieder erreichbar und morgen wechsle ich die Bank

Heute war mein letzter Urlaubstag und somit sind alle Urlaubstage von 2009 verbraten. Morgen beginnt wieder der Ernst des Lebens.

Dafür funktioniert der Blog und das Forum wieder einwandfrei. Gefühlt schneller als vorher. Irgendwie gab es auf Seiten meines Anbieters wohl gehörige Serverprobleme, deren Lösung länger gedauert hat als in der Email geschätzt. Oder der Server hat sich noch einmal verabschiedet. Naja shit happens und ich bin immer noch innerhalb der “99,6 % Verfügbarkeit im Jahresmittel”. Hört sich doch eigentlich sehr gut an. Rechnet man das allerdings mal aus, kommt man (sofern ich nicht zu blöd zum rechnen bin) auf knappe 1,5 Tage an denen meine Seite nicht erreichbar sein darf. Mal sehen wie es weitergeht. Ich bin da allerdings guter Dinge. Ausrutscher passieren. Und für manche Ausfälle kann man ja nun wirklich nichts.

Morgen leite ich dann noch den Umzug von der VR-Bank zur Hypovereinsbank ein. Das wird bestimmt lustig. Also für mich, nicht für die VR-Bank.

Allgemein